System Requirements

The following are required for Omnicron to operate fully:

  • Joomla 1.5.x (latest version)
  • Gantry v3.0.10 or higher
  • PHP 5.2 or higher
  • RokNavMenu Module

Service Updates

OFFLINE: 31.08.10 @ 12:31 EST. Sharing hosting servers are currently disabled due to a backup error. http://bit.ly/bWZUiKq
RESTORED: 29.08.10 @ 18:53 EST. Email has been restored. All received messages are now synced. http://bit.ly/cWXUiFt
OFFLINE: 28.08.10 @ 23:14 EST. Our email system is down. Backup servers are trapping all sent emails. http://bit.ly/wQDSpKl

Our Partners

Sponsors